starslingdev - Disruption with some GitHub services – Incident details

All systems operational

Disruption with some GitHub services

Resolved
Partial outage
Started 2 days agoLasted about 1 hour

Affected

Third Party: GitHub → Actions

Operational from 4:17 PM to 4:20 PM, Degraded performance from 4:20 PM to 4:28 PM, Partial outage from 4:28 PM to 4:41 PM, Degraded performance from 4:41 PM to 5:16 PM, Operational from 5:16 PM to 5:36 PM

Third Party: GitHub → API Requests

Operational from 4:17 PM to 4:17 PM, Degraded performance from 4:17 PM to 5:16 PM, Operational from 5:16 PM to 5:36 PM

Third Party: GitHub → Pull Requests

Operational from 4:17 PM to 4:20 PM, Degraded performance from 4:20 PM to 5:16 PM, Operational from 5:16 PM to 5:36 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

  • Update
    UTC
    Update

    We are seeing recovery across all services

  • Update
    UTC
    Update

    The degradation affecting API Requests, Actions, Copilot, Issues, Pages and Pull Requests has been mitigated. We are monitoring to ensure stability.

  • Update
    UTC
    Update

    Actions is experiencing degraded performance. We are continuing to investigate.

  • Update
    UTC
    Update

    Actions is experiencing degraded availability. We are continuing to investigate.

  • Update
    UTC
    Update

    Pages is experiencing degraded performance. We are continuing to investigate.

  • Update
    UTC
    Update

    Copilot is experiencing degraded performance. We are continuing to investigate.

  • Update
    UTC
    Update

    We are investigating timeouts to some GitHub services

  • Update
    UTC
    Update

    Pull Requests is experiencing degraded performance. We are continuing to investigate.

  • Investigating
    UTC
    Investigating

    We are investigating reports of degraded performance for API Requests and Issues