starslingdev - GitHub search is degraded – Incident details

All systems operational

GitHub search is degraded

Resolved
Major outage
Started about 1 month agoLasted about 6 hours

Affected

Third Party: GitHub → Actions

Operational from 4:31 PM to 4:31 PM, Degraded performance from 4:31 PM to 8:35 AM

Third Party: GitHub → Pull Requests

Operational from 4:31 PM to 4:53 PM, Degraded performance from 4:53 PM to 8:13 AM

Updates
  • Update
    Update

    We're continuing to see connectivity issues reaching elasticsearch. Impact on downstream services will be intermittent as we find the root cause

  • Update
    Update

    Users are experiencing intermittent failures to view issues, pull requests, projects and Actions workflow runs.

    We are still investigating and attempting mitigations. We will provide further updates.

  • Update
    Update

    Pull Requests is experiencing degraded performance. We are continuing to investigate.

  • Update
    Update

    Packages is experiencing degraded performance. We are continuing to investigate.

  • Update
    Update

    Issues is experiencing degraded performance. We are continuing to investigate.

  • Update
    Update

    Customers across GitHub are experiencing failures with searches. Examples include: workflow run failures, projects failing to load, and timed out search requests. This is due to an ongoing infrastructure issue that we have been investigating.

  • Investigating
    Investigating

    We are investigating reports of degraded performance for Actions