starslingdev - Incident with Pull Requests – Incident details

All systems operational

Incident with Pull Requests

Resolved
Degraded performance
Started 4 days agoLasted about 1 hour

Affected

Third Party: GitHub → Pull Requests

Degraded performance from 10:13 PM to 10:27 PM, Operational from 10:27 PM to 11:22 PM

Updates
  • Resolved
    UTC
    Resolved

    On September 20, 2026, between 21:46 and 22:24 UTC the Pull Requests service was degraded and pull request merge and test-merge commits were created late, with delays reaching approximately four minutes at peak. Merge commits were delayed rather than lost. Because some Actions workflow runs start only after a pull request's merge commit is created, a subset of workflow runs for pull request events were also delayed.

    This was due to a routine repository maintenance job for an unusually large repository consuming nearly all of the memory on a single Git storage server, which left that server unable to serve the Git operations used to create merge commits.

    We mitigated the incident by removing the affected server from service at 22:18 UTC, after which the queued merge commits were created within six minutes.

    We have capped the memory a single repository maintenance job may consume so that one repository cannot exhaust a server, and we have improved monitoring and alerting on storage server health to reduce our time to detection and mitigation of issues like this one in the future.

  • Update
    UTC
    Update

    A git fileserver issue caused a brief delay in creating some merge commits - we've isolated the underlying server and already observed recovery.

  • Monitoring
    UTC
    Monitoring

    The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.

  • Investigating
    UTC
    Investigating

    We are investigating reports of degraded performance for Pull Requests