starslingdev - Incident with several GitHub Services – Incident details

All systems operational

Incident with several GitHub Services

Resolved
Major outage
Started 2 days agoLasted about 1 hour

Affected

Third Party: GitHub → Actions

Operational from 9:16 AM to 9:25 AM, Degraded performance from 9:25 AM to 10:44 AM

Third Party: GitHub → API Requests

Degraded performance from 9:16 AM to 10:44 AM

Third Party: GitHub → Pull Requests

Major outage from 9:16 AM to 10:28 AM, Degraded performance from 10:28 AM to 10:44 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

  • Update
    UTC
    Update

    Pull Requests is experiencing degraded performance. We are continuing to investigate.

  • Update
    UTC
    Update

    We have reduced load on this cluster with internal load-shedding and are seeing signs of recovery but continue to monitor

  • Update
    UTC
    Update

    We're seeing increased database replication delays on collab which is causing increased error rates in authorization endpoints and follow-on increased error rates across the system - we are investigating

  • Update
    UTC
    Update

    Actions is experiencing degraded performance. We are continuing to investigate.

  • Investigating
    UTC
    Investigating

    We are investigating reports of degraded availability for API Requests, Issues, Pages and Pull Requests