starslingdev - Latency issues across a number of services – Incident details

All systems operational

Latency issues across a number of services

Resolved
Partial outage
Started 3 days agoLasted about 2 hours

Affected

Third Party: GitHub → Actions

Operational from 7:53 AM to 7:53 AM, Partial outage from 7:53 AM to 9:22 AM, Operational from 9:22 AM to 9:39 AM

Third Party: GitHub → Webhooks

Operational from 7:53 AM to 7:53 AM, Degraded performance from 7:53 AM to 9:35 AM, Operational from 9:35 AM to 9:39 AM

Third Party: GitHub → Pull Requests

Operational from 7:53 AM to 9:18 AM, Degraded performance from 9:18 AM to 9:27 AM, Operational from 9:27 AM to 9:39 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.

  • Monitoring
    UTC
    Monitoring

    The degradation has been mitigated. We are monitoring to ensure stability.

  • Update
    UTC
    Update

    Webhooks is operating normally.

  • Update
    UTC
    Update

    The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.

  • Update
    UTC
    Update

    We identified the source of latency affecting multiple services and applied a fix. Issues and Actions are recovering, and remaining affected services are seeing improvement as processing backlogs clear. We are actively monitoring recovery across all services.

  • Update
    UTC
    Update

    The degradation affecting Issues has been mitigated. We are monitoring to ensure stability.

  • Investigating
    UTC
    Investigating

    We are investigating reports of degraded availability for Actions, Issues and Webhooks